jUCMNav Quick Installation

jUCMNav requires J2SE 1.5 (or JRE 1.5), Eclipse 3.1.0 (or more recent), the Graphical Editing Framework (GEF) 3.1, and the Eclipse Modeling Framework (EMF) 2.1.0. The versions provided below are known to work well together.

  1. Extract the zip file for Eclipse 3.1.0 to the Program Files directory (in case you want more information see Eclipse Downloads). If you have already installed a previous version of Eclipse, do one of the following: either rename your current Eclipse directory to something else than eclipse and then install the new version or use the Help-Software Updates-Manage Configuration feature of Eclipse to replace your current version with the new one.
  2. Extract the zip file for GEF 3.1 to the Program Files directory (in case you want more information see the GEF Project Home Page).
  3. Extract the zip file for EMF 2.1.0 to the Program Files directory (in case you want more information see the EMF Project Home Page). If prompted, you may overwrite the two html files.
  4. Copy the jar file for the latest jUCMNav to your Program Files\eclipse\plugins directory (in case you want more information see the jUCMNav 2 Release Page).
  5. Add a shortcut for Program Files\eclipse\eclipse.exe to your start menu.
  6. The first time you start Eclipse after installing new software, it is a good idea to start Eclipse from the command prompt with the -clean option.
  7. Optionally, you may also want to execute the setup file for Graphviz 2.6 to install autolayout capabilities for jUCMNav. Use all default settings when installing Graphviz.
  8. You are now ready! Open a project (or create a new one), add a new jUCMNav file to it (Ctrl-N), and then have fun with jUCMNav!

-- DanielAmyot - 21 Feb 2006
Topic revision: r2 - 04 Aug 2006, DanielAmyot
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback